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Find the Exit

In this game, you will be able to add movement to a character by translating (or
moving) the object at a fixed rate of time.

Your mission: Escape the maze in the least amount of time possible. If you press
Play, you'll discover you are trapped! The player character, Codey, can't move yet
because there is no movement code.

Code your player character's movement. This is a key step in making your game

because it lets the player character, Codey, move around the game, advance
through challenges and reach their goal!

Now that you know your mission, let's get moving!
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1 Start a new Unity Project and name it YOUR INITIALS - Find the Exit.
Select 3D core.

2 We will be using Cinemachine to control our camera. This will help us
create awesome camera shots and angles for our game. Go ahead and
open Window > Package Manager.

Be patient if it doesn’t open Window Help
right away. It might take a Next Window Ctrl+Tab
minute to load. Previous Window Ctrl+Shift+ Tab

Layouts ¥

Acset Store Ctrl+9
Package Manager

Asset Management ¥

TextheshPro ¥
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3 Switch to the Unity Registry in the top left corner, then find
Cinemachine and click Install in the top right of the window.

Cinemachine
2 - May 08

4 We've created a starter pack to give you a head start! To use it, import
the Activity 02 - Find the Exit.unitypackage by going to Assets >
Import Package > Custom Package> All > Import.

Hold on...

Importing scripts.,

Cancel
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5 To open the starter package, double-click on the FindTheExit scene.
You can find this in the Project tab under Assets > Scenes >
FindTheEXxit.
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6 We should check that Cinemachine is working like it is meant to.
In the Hierarchy tab, you should see a list of all the game objects in the
scene. If you see a little grey and red icon

attached to the Main Camera (shown in L :;i” ':“ml"” L
. . . . . Vizam
the picture), Cinemachine is working! k".’_.'
If you do not see it, go into the Assets
tab and press Reimport All.
Assets  GameObject  Component  Window  Helg

Create R Then after Unity is done importing,

Show in Explorer check the Main Camera again.
Open

Delete

Rename

Copy Path Alt+ Ctrl+C

Open Scene Additive Are you sure you want to reimport all assets? n

Import New Asset... Rebuilding assets is only used if your project has been
@ corrupted due to an internal Unity bug. It can take

Import Package several hours to complete, depending on the size of
Export Package... Your project.
Please submit a bug report detailing the steps leading

Find References In Scene
up to here.

Select Dependencies

I Reimpart

Refresh Ctrl
Reimport

Reimport All

@ Codey

Codey will be the main character in several Silver Belt games! You will learn

how to make him move, jump, and interact with the world around him.
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7 Now you can start creating the
script to give Codey the ability to
move in the game!

To get started, go to the Hierarchy
and click the Player game object to
open it in the Inspector tab.

The Inspector is where you can see
all of the components and
properties of a single game object in
your scene.

i= Hierarchy

| Create "'l farall 1

v € FindTheExit

> i CFX_MagicPoof
> by gem
‘jcastleTurr’et
> Walls
__ Ground

. Directional Light- Purpl
. Directional Light- Blue

. Directional Light- Orang
¥ [ JExit
. fouEscaped
huTlmer

F L odey
__ Main Camera
. CM vecaml

8 In the Inspector, click Add

Component and search

Add Component

for “script”. Click on New = e

Script.

MNew script

Search
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9 Name the script

“PlayerMovement” and press Add Component

Enter or click Create and Add. "CL PlayerMovement @)
L4 New script

In the Project tab, move the new Name

PlayerMovement script to the PlayerMavement |

Scripts folder to keep things

organized.

Staying organized is important
so you can find what you need
when you need it.

E Create and Add j

1 0 After you have saved and moved the script to the correct folder,
double-click on the PlayerMovement script in the Inspector to open
the file in Visual Studio. This is where you'll add code to get Codey in
motion!

v o W Player Movsmant [ Srri [Fal =t

Script PlayerMovement @
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1 1 First, we need to set a speed for Codey. On a new line before void
Start(), type public float speed = 5; to initialize Codey’s speed.
A public variable can be changed in the Inspector. We want the value
of speed to be a float
because that means we
can have decimal values
and not just whole
numbers.

1 2 In the Update function, we want to add one line of code to move our
ninja, Codey.

To do this, let's try using Unity’s Translate function on Codey's
transform. Unity's Translate function will let us change an object’s

position. In the void Update() function, type
transform.Translate(Vector3.forward * speed *
Time.deltaTime); to tell Codey to move forward at our set speed of 5

at a constant rate of time.

transform.Translate(Vector3.forward * speed * Time.deltaTime);

All we do when we Translate an object in Unity or in the real world is
move it from one location to another.
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A Vector3 is a special object that contains three numbers, one for each of the

Vector 3

directions in 3D space. We are using Vector3.forward to ask Unity to give us
a vector that points forward.

Time.deltaTime

Time.deltaTime is a fancy way of asking Unity to give the value for how
much time has passed since the last time the game loop updated. We use it
to make sure any movements and other calculations are not done too
slowly or too quickly. We want them to be done exactly right each time!

1 3 Save your code and press Play.
Codey should translate
forward at a speed of 5. But
what about at higher speeds?
Try changing your speed
variable and see what happens
at high speeds.

Something seems wrong!

Codey can move through walls

at high speeds! This is because transform.Translate doesn’t take
into account any walls if the distance it is moving is on the other side
of the wall. Instead, let’'s try using Rigidbody and Velocity!
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1 4 Comment out your previous line so that it will not run.

1 5 Get the Rigidbody component from Codey, and then we will set the
velocity to the forward direction at the speed we set. Try out different
speeds now and see the difference! Next, let's get Codey moving with
arrow keys!

GetComponent<Rigidbody>().velocity = Vector3.forward * speed;
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1 6 Let's first see how Unity interprets user input. Go to Edit > Project
Settings > Input Manager. Expand the Axes settings by clicking on the
drop-down arrow next to it. This Project Settings panel will show a lot
of behind-the-scenes Unity settings. For Horizontal, notice the right
arrow and d are listed as Positive Button, meaning it will output a 1.
While the left arrow and a are listed as Negative Button, meaning it
will output a -1. Close the Project Settings window.

Al - Find the Exit - FindTheExit - Windows, Mac, Linux - Unity 2022.3.18f1% <DX11>
File Edit Assets GameObject Component Services Window Help
Undo Modified 3 properties in Qu... Chrl+Z
X Project Settings
Undo History Ctrl+U
Select All Ctrl+A erformance Input Manager
Deselect All Shift+D
Select Children Shift+C
Select Prefab Root Ctrl+Shift+R
Invert Selection Chrl+l

Cut Ctrl+ X
Copy Ctr+C
Paste Ctrl+V

Horizontal

Duplicate Ctrl+D
Rename

Delete

Frame Selected F
Lock View to Selected Shift+F

Find Ctrl+F
Search All... Ctrl+K se Button -

-

Play Ctrl+P
Pause Ctrl+Shift+P
Step Ctrl+Alt+P

tion from all Joysticks »

Sign out
Selection

Project Settings...
Preferences...
Shortcuts...

Clear All PlayerPrefs

Graphics Tier
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1 7 Go back to your PlayerMovement script. After the
GetComponent<Rigidbody> () line, log the value of the horizontal axis
by typing Debug.Log(Input.GetAxisRaw(“Horizontal”)); inthe
Update function.

e()

GetComponent<Rigidbody>().velocity = Vector3.forward * speed;
Debug. Log{Input.GetAxisRaw("Horizontal™));

On every frame, Unity will receive the user input, and get the value for
the horizontal axis. With Debug, we are then asking Unity to log that
value into the console.

1 8 Before you play the game, what number do you think will be in the log
when you press the a key? The d key?

What about the left and right arrows? What will happen if you don't
press any keys? Write your answers down somewhere so you can
check to see if you were right!

1 9 Play your game and look at the console. It will display a @ if there is no
player input. Now press the left arrow or a; the console should have a
new log saying -1. Next, test out the right arrow and d. Did you get it
right?

@ [11:50:21] -1
UnityEngine.Debug:Log{Object)

@ [11:50:21] 0
UnityEngine.Debug:Log(Object)

Before moving on to the next step, think about what would happen if
you wrote Vertical in your script instead of Horizontal? Test out your
guess! Once you are done, you can delete the Debug. Log line from the
Update function.

@ CODENINJAS'




‘

20 We now understand how to read player input to get -1 or 1 depending
on which key the user is pressing, but how can we connect this to the
movement of Codey?

Remember, we are using Vector3.Forward to move our character.
This will make Codey always move forward and ignore the user’s
input. Before we change the Rigidbody’s velocity, let's make a new
Vector3 based on user inputs!

21 Above the GetComponent<Rigidbody>() line, declare a new float
variable named horizontal to store the value of the user input’s
horizontal axis by typing:
float horizontal = Input.GetAxisRaw(“Horizontal”);

horizontal = Input.GetAxisRaw("Horizontal");
GetComponent<Rigidbody>() .velocity = Vector3.forward * speed;

22 On the next line after float horizontal, write a similar piece of code
but for the Vertical axis. Don't forget to check your work!

1 = Input.GetAxisRaw("Horizontal");
= Input.GetAxisRaw("Verti
oid

GetComponent<Rigidbody>().velocity = Vector3.forward * speed;

23 Play your game and see what happens.
Codey still always moves in a straight line! This is because while we
are getting the user input, we aren’t using it to move Codey!
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24 On the next line, create a new Vector3 destination with three
parameters of horizontal, 9, and vertical by typing Vector3
destination = new Vector3(horizontal, 0, vertical);.

This will create a new vector that will change based on the user input!
Our horizontal variable is in the x value spot to move the character
left and right, and the vertical variable is in the z value spot to move
the character forward and backward in the game world. The y-axis
would be used for moving the character up and down above the game
world, like for jumping or falling. If you want to see what this vector
looks like, you can Debug. Log it to the console.

()

horizontal Input .GetAxisRaw(

vertical = Input.GethAx wi( ™

Vector3(horizontal, @, vertical);

GetComponent<Rigidbody>().velocity = Vector3.forward * speed;

A parameter, or argument, is a value or variable that we give to a function by placing it
inside parentheses.

25 Codey will still ignore user input because we haven’t told Codey to
move based on the destination vector we just made. In the final line of
Update, change Vector3. forward to destination. Save and test out
your gamel!

()

vertical = Input.GetAxisR

or3 destination =
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26 In the Update function, change Input.GetAxisRaw to Input.GetAxis.
Now play the game.

Did you notice a change in how Codey moves? If you didn't, that's
okay! Input.GetAxisRaw is like an on/off switch. Either the useris
pressing a key (value 1) or the user is not pressing a key (value 9).
Input.GetAxis will behave slightly differently.

If a user is not pressing a key, the value will always be 8. As soon as a
user presses a key, the value will start slowly increasing from 0 to 1.

This will mean that Codey will slowly speed up until the
Input.GetAxis value reaches 1.

While it might not make a big difference for all games and player
movement code, sometimes this very small difference can make a big
impact on the enjoyment of someone playing your game!

This is your game, you decide which way you like better:

Input.GetAxisRaw or Input.GetAxis!
0

horizontal = Input.GetAxis("Horizontal");

vertical = Input.GetAxis("Vertical™);
Vector3 destination = Vector3(horizontal, @, vertical);

GetComponent<Rigidbody>().velocity = destination * speed;
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27 Now that you have Codey responding to the user’s input, you can
change the destination vector!

You can try switching the places of horizontal and vertical, making
one variable negative, changing the y value to be 5 instead of @, or
anything else you want to try.

By changing these values and playing the game to see what happens,
you can gain a better understanding of what Input and Rigidbody's
velocity are doing to your ninja.
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